summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 6fa0ff4..9227148 100644
--- a/meson.build
+++ b/meson.build
@@ -70,6 +70,10 @@ if get_option('gtk')
gtk_dep = dependency('gtk+-3.0', version: '>=' + gtk_min_version)
endif
+if get_option('gtk4')
+ gtk4_dep = dependency('gtk4')
+endif
+
# configuration
conf = configuration_data()
conf.set_quoted('VERSION', meson.project_version())
@@ -100,6 +104,9 @@ subdir('schema')
if get_option('gtk')
subdir('ui')
endif
+if get_option('gtk4')
+ subdir('gcr-gtk4')
+endif
if get_option('gtk_doc')
subdir('docs')
endif