summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMichael Catanzaro <mcatanzaro@gnome.org>2021-01-07 14:58:02 -0600
committerMichael Catanzaro <mcatanzaro@gnome.org>2021-01-07 14:59:49 -0600
commita863f121cbbbada1325b0561521b1f60e8bba4ee (patch)
tree3aa1fa4347d709d61df2b5f53f9784b87861ddfc /meson.build
parent5af696a750a563753dbc71b086a1968765780371 (diff)
downloadepiphany-a863f121cbbbada1325b0561521b1f60e8bba4ee.tar.gz
Remove enable_gsb meson option
This should be a feature option, not a bool option. Anyway, it doesn't matter, since it's redundant with the API key option.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 1 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index 593fcec32..2ef46a8b3 100644
--- a/meson.build
+++ b/meson.build
@@ -70,10 +70,7 @@ conf.set_quoted('VERSION', '@VCS_TAG@')
gsb_api_key = get_option('gsb_api_key')
conf.set_quoted('GSB_API_KEY', gsb_api_key)
-if gsb_api_key != ''
- message('GSB API Key provided')
-endif
-conf.set10('ENABLE_GSB', get_option('enable_gsb'))
+conf.set10('ENABLE_GSB', gsb_api_key != '')
glib_requirement = '>= 2.61.2'
gtk_requirement = '>= 3.24.0'