summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMichael Catanzaro <mcatanzaro@igalia.com>2019-02-09 10:27:08 -0600
committerMichael Catanzaro <mcatanzaro@igalia.com>2019-03-04 15:13:39 -0600
commiteefe59f7b540d2a8e73982566265dd083e21de01 (patch)
treeb65f0ceb7df4448187f474e8560ff19a7931a765 /meson.build
parentfd31a389627ad641616f037517cfb014f314d1a3 (diff)
downloadepiphany-eefe59f7b540d2a8e73982566265dd083e21de01.tar.gz
uri-helpers: Use webkit_uri_for_display()
We'll use WebKit's code for processing punycode and IDN. This also means we'll adopt the same IDN homograph mitigation strategy as Safari, rather than the current implementation based on Firefox.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 1 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index a518dbb39..ae54b7b5c 100644
--- a/meson.build
+++ b/meson.build
@@ -79,7 +79,7 @@ endif
glib_requirement = '>= 2.56.0'
gtk_requirement = '>= 3.24.0'
nettle_requirement = '>= 3.4'
-webkitgtk_requirement = '>= 2.21.92'
+webkitgtk_requirement = '>= 2.23.90'
cairo_dep = dependency('cairo', version: '>= 1.2')
gcr_dep = dependency('gcr-3', version: '>= 3.5.5')
@@ -92,7 +92,6 @@ gsettings_desktop_schemas = dependency('gsettings-desktop-schemas')
gtk_dep = dependency('gtk+-3.0', version: gtk_requirement)
gtk_unix_print_dep = dependency('gtk+-unix-print-3.0', version: gtk_requirement)
hogweed_dep = dependency('hogweed', version: nettle_requirement)
-icu_uc_dep = dependency('icu-uc', version: '>= 4.6')
iso_codes_dep = dependency('iso-codes', version: '>= 0.35')
json_glib_dep = dependency('json-glib-1.0', version: '>= 1.2.4')
libdazzle_dep = dependency('libdazzle-1.0', version: '>= 3.31.90')