summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJan-Michael Brummer <jan.brummer@tabos.org>2019-05-12 01:02:09 +0200
committerJan-Michael Brummer <jan.brummer@tabos.org>2019-05-13 19:02:52 +0200
commitcae625ba5e53b7f731eae899979cec64f4040b09 (patch)
tree87360f74e4d7840d97622930fe5cd467033c847b /meson.build
parentea4fb468bb2e4e63fab985f8924d89777abb8ff7 (diff)
downloadepiphany-cae625ba5e53b7f731eae899979cec64f4040b09.tar.gz
Rename webextension to webprocessextension
In order to avoid future conflicts with official web browser web extension, rename our current webextensions to webprocessextension.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 359ccbf62..b7af3b426 100644
--- a/meson.build
+++ b/meson.build
@@ -27,7 +27,7 @@ pkgdatadir = join_paths(datadir, 'epiphany')
pkglibdir = join_paths(libdir, 'epiphany')
pkglibexecdir = join_paths(libexecdir, 'epiphany')
servicedir = join_paths(datadir, 'dbus-1', 'services')
-webextensionsdir = join_paths(pkglibdir, 'web-extensions')
+webprocessextensionsdir = join_paths(pkglibdir, 'web-process-extensions')
iso_codes = dependency('iso-codes')
iso_codes_prefix = iso_codes.get_pkgconfig_variable('prefix')
@@ -45,7 +45,7 @@ conf.set_quoted('BUILD_ROOT', meson.build_root())
developer_mode = get_option('developer_mode')
conf.set10('DEVELOPER_MODE', developer_mode)
conf.set_quoted('DISTRIBUTOR_NAME', distributor_name)
-conf.set_quoted('EPHY_WEB_EXTENSIONS_DIR', webextensionsdir)
+conf.set_quoted('EPHY_WEB_PROCESS_EXTENSIONS_DIR', webprocessextensionsdir)
conf.set_quoted('GETTEXT_PACKAGE', meson.project_name())
conf.set_quoted('ISO_CODES_PREFIX', iso_codes_prefix)
conf.set_quoted('LIBLOCALEDIR', liblocaledir)