summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMichael Catanzaro <mcatanzaro@igalia.com>2019-06-11 09:47:34 -0500
committerJan-Michael Brummer <jan.brummer@tabos.org>2019-06-11 20:41:21 +0000
commit95a8d6340ee6c482aa6f63429e563c9dc8af7ca9 (patch)
treee7f2834d7f3b78c0b9d7437877e9e42f7707479b /meson.build
parent3a3d32efb169a5a371aaff74fe4ce052e7507f82 (diff)
downloadepiphany-95a8d6340ee6c482aa6f63429e563c9dc8af7ca9.tar.gz
Restore original version format
This changes our version for Tech Preview builds, from, e.g.: Web 3.33.2-7b76a6a38 Back to: Web 3.33.2-7-g7b76a6a38+ which is nicer as it shows the -7- so we can see how many commits we are past the last tag, and the + showing whether there are uncommitted changes. It also removes the build profile from the version number, so we don't show "stable" after the version number in stable releases (oops!).
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 1 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index d1a28c185..f77d8bbe9 100644
--- a/meson.build
+++ b/meson.build
@@ -62,12 +62,10 @@ conf.set('EPHY_MAJOR_VERSION', version_array[0].to_int())
conf.set('EPHY_MINOR_VERSION', version_array[1].to_int())
conf.set('EPHY_MICRO_VERSION', version_array[2].to_int())
-conf.set_quoted('VERSION', '@0@-@VCS_TAG@'.format(meson.project_version()))
+conf.set_quoted('VERSION', '@VCS_TAG@')
config_h = declare_dependency(
sources: vcs_tag(
- command: ['git', 'rev-parse', '--short', 'HEAD'],
- fallback: get_option('profile') != 'default' ? 'devel' : 'stable',
input: configure_file(
output: 'config.h.in',
configuration: conf