summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorCarlos Garcia Campos <cgarcia@igalia.com>2019-01-03 15:25:46 +0100
committerCarlos Garcia Campos <carlosgc@gnome.org>2019-01-04 13:11:00 +0100
commit28a84367b866dd277d7f3a0f063d20ccef240a4e (patch)
tree72761f51d554e1a5ca97fcd647b6202a96158e65 /meson.build
parentd8767ea1790368e7cb65c9e6f2e225dd9ba0a31e (diff)
downloadepiphany-28a84367b866dd277d7f3a0f063d20ccef240a4e.tar.gz
Add automation mode
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 29e266b27..b50bb4f40 100644
--- a/meson.build
+++ b/meson.build
@@ -49,6 +49,11 @@ conf.set10('TECH_PREVIEW', tech_preview)
conf.set_quoted('VERSION', meson.project_version())
+version_array = meson.project_version().split('.')
+conf.set('EPHY_MAJOR_VERSION', version_array[0].to_int())
+conf.set('EPHY_MINOR_VERSION', version_array[1].to_int())
+conf.set('EPHY_MICRO_VERSION', version_array[2].to_int())
+
configure_file(
output: 'config.h',
configuration: conf