summaryrefslogtreecommitdiff
path: root/lib/meson.build
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2017-08-28 10:57:19 +0100
committerEmmanuele Bassi <ebassi@gnome.org>2017-08-28 13:07:54 +0100
commit13d3aa20ceb1911616956e308057475105e4e4f0 (patch)
tree92187f40d2126e46bba3fd5ae042925d67c6b95c /lib/meson.build
parentc8fd73c8f2c28f7278477bb37bda64d6b88a3d4e (diff)
downloadepiphany-13d3aa20ceb1911616956e308057475105e4e4f0.tar.gz
build: Add dependency on generated header
The ephy-widgets sub-library depends on the generated enumeration header file on its parent directory. If this dependency is not appropriately expressed, there's no guarantee that the header will be generated before the sources in the widgets library are compiled, which means there will be occasional and non-deterministic build failure — say, for instance, on highly parallel builds on fast machines like the one that runs the Continuous integration build for GNOME.
Diffstat (limited to 'lib/meson.build')
-rw-r--r--lib/meson.build8
1 files changed, 5 insertions, 3 deletions
diff --git a/lib/meson.build b/lib/meson.build
index aa1055756..958299518 100644
--- a/lib/meson.build
+++ b/lib/meson.build
@@ -4,12 +4,14 @@ types_headers = [
'history/ephy-history-types.h'
]
-enums = gnome.mkenums('ephy-lib',
+lib_enums = gnome.mkenums('ephy-lib',
sources: types_headers,
h_template: 'ephy-lib-type-builtins.h.in',
c_template: 'ephy-lib-type-builtins.c.in'
)
+ephy_lib_type_builtins_h = lib_enums[1]
+
libephymisc_sources = [
'contrib/eggtreemultidnd.c',
'contrib/gvdb/gvdb-builder.c',
@@ -47,7 +49,7 @@ libephymisc_sources = [
'history/ephy-history-service-urls-table.c',
'history/ephy-history-service-visits-table.c',
'history/ephy-history-types.c',
- enums
+ lib_enums
]
libephymisc_deps = [
@@ -87,7 +89,7 @@ ephymisc_dep = declare_dependency(
link_with: libephymisc,
include_directories: libephymisc_includes,
dependencies: libephymisc_deps,
- sources: enums
+ sources: lib_enums
)
subdir('sync')