summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Catanzaro <mcatanzaro@gnome.org>2016-08-08 07:24:15 -0500
committerMichael Catanzaro <mcatanzaro@gnome.org>2016-08-08 07:26:37 -0500
commit2bb9c5751e9ec5212826b970ea7a57549dba9fb3 (patch)
treead641df8c9ae5e830b96a7dce92190bcf0178769 /configure.ac
parent6fa20334d09ae245a3c3b47bab924b56c601ccd7 (diff)
downloadepiphany-2bb9c5751e9ec5212826b970ea7a57549dba9fb3.tar.gz
configure: make changelog generation code more explicit
Instead of hiding tag construction behind version macros.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 002f2dd99..2d3e3333b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -19,8 +19,8 @@ m4_define([epiphany_version_minor],[21])
m4_define([epiphany_version_micro],[4])
m4_define([epiphany_version],[epiphany_version_major.epiphany_version_minor.epiphany_version_micro])
-m4_define([epiphany_previous_version_major],[3])
-m4_define([epiphany_previous_version_minor],[20])
+dnl Must be a valid git tag
+m4_define([epiphany_changelog_start],[3.20.0])
AC_INIT([GNOME Web Browser],[epiphany_version],[http://bugzilla.gnome.org/enter_bug.cgi?product=epiphany],[epiphany])
AX_IS_RELEASE([git-directory])
@@ -32,14 +32,14 @@ AC_CONFIG_MACRO_DIRS([m4 libgd])
AC_CONFIG_HEADERS([config.h])
AC_CONFIG_SRCDIR([configure.ac])
-AC_SUBST([EPIPHANY_CHANGELOG_START],[epiphany_previous_version_major.epiphany_previous_version_minor.0])
-
AX_CHECK_ENABLE_DEBUG([yes])
AX_CODE_COVERAGE
AX_COMPILER_FLAGS([WARN_CFLAGS], [WARN_LDFLAGS], [$ax_is_release], [],
dnl TODO: Remove! These warnings should be fixed, not silenced.
[-Wno-deprecated-declarations])
+
AX_GENERATE_CHANGELOG
+AC_SUBST([EPIPHANY_CHANGELOG_START],[epiphany_changelog_start])
AC_PROG_CC