summaryrefslogtreecommitdiff
path: root/viewer/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'viewer/Makefile.am')
-rw-r--r--viewer/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/viewer/Makefile.am b/viewer/Makefile.am
index e666b076..bdf4a6c2 100644
--- a/viewer/Makefile.am
+++ b/viewer/Makefile.am
@@ -1,3 +1,8 @@
+if ENABLE_JPEG
+jpeg_LIB = -L$(top_builddir)/jpegutils -leog-jpegutils
+jpeg_DEPS = $(top_builddir)/jpegutils/libeog-jpegutils.a
+endif
+
INCLUDES = \
-DGNOMELOCALEDIR=\""$(prefix)/$(DATADIRNAME)/locale"\" \
-DG_LOG_DOMAIN=\"Eog\" \
@@ -21,11 +26,13 @@ eog_image_viewer_SOURCES = \
eog_image_viewer_DEPENDENCIES = \
$(top_builddir)/libeog/libeog.a \
- $(top_builddir)/libgpi/libgpi.a
+ $(top_builddir)/libgpi/libgpi.a \
+ $(jpeg_DEPS)
eog_image_viewer_LDADD = \
-L$(top_builddir)/libeog -leog \
-L$(top_builddir)/libgpi -lgpi \
+ $(jpeg_LIB) \
$(EOG_LIBS) \
$(X_LIBS) \
$(LIBJPEG)