summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJens Finke <jens@triq.net>2003-12-08 18:09:30 +0000
committerJens Finke <jens@src.gnome.org>2003-12-08 18:09:30 +0000
commit936c0034075dd59f6f0dc8f5b0f85972c1e63c08 (patch)
tree44bd7e4f4b78d17b9288e509e3f98bf61c534f58 /Makefile.am
parentbe524a21e3a5d8a644f448f1d715b1b30fb5ea4a (diff)
downloadeog-936c0034075dd59f6f0dc8f5b0f85972c1e63c08.tar.gz
Lossless saving for local/unmodified files and local/modified jpeg images.
2003-12-08 Jens Finke <jens@triq.net> Lossless saving for local/unmodified files and local/modified jpeg images. Needs more testing. * Makefile.am: * acconfig.h: Added jpegutils compile magic. * configure.in: Bumped version to 2.5.1. Define ENABLE_JPEG. * viewer/Makefile.am, * collection/Makefile.am: Link to libeog-jpegutils conditionally. * libeog/Makefile.am: Include jpegutils dir. * libeog/eog-image-jpeg.[ch]: Build only if HAVE_JPEG is true. (eog_image_jpeg_save_lossless): New function. * libeog/eog-image-private.h: New file_type attribute. * libeog/eog-image.c (real_image_load): Store file format used for loading of the image. (is_local_uri), (get_save_file_type_by_suffix): New functions. (eog_image_save): Reworked function. Tries to be as smart as possible in using the least lossy save method. * libeog/eog-transform.[ch] (eog_transform_get_transform_type): New function. * jpegutils/*: New files, borrowed from GThumb.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index ee38cafb..54f7f67d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,4 +1,9 @@
-SUBDIRS = art idl libgpi libeog viewer collection shell po help
+if ENABLE_JPEG
+jpeg_DIRS = jpegutils
+endif
+
+SUBDIRS = art idl libgpi $(jpeg_DIRS) libeog viewer collection shell po help
+DIST_SUBDIRS = $(SUBDIRS) jpegutils
EXTRA_DIST = \
DEPENDS \