summaryrefslogtreecommitdiff
path: root/tests/conform/Makefile.am
diff options
context:
space:
mode:
authorNeil Roberts <neil@linux.intel.com>2012-02-29 11:19:56 +0000
committerNeil Roberts <neil@linux.intel.com>2012-03-05 17:43:46 +0000
commitb6dc23370d242e68afd5436d6c531b79d8e5e843 (patch)
tree8c9954b9ccc8afe749b4bbf36a4c11e5f8086e92 /tests/conform/Makefile.am
parent59fd9b49d93b0d1326083f6546370d939a659597 (diff)
downloadcogl-b6dc23370d242e68afd5436d6c531b79d8e5e843.tar.gz
Add a conformance test for reading back an RGBA texture as alpha-only
This just creates a 1x1 RGBA texture and then reads it back in COGL_PIXEL_FORMAT_A_8 format. Gnome Shell is doing this to create a shadow and I accidentally broke it so this should hopefully stop that happening again. https://bugzilla.gnome.org/show_bug.cgi?id=671016 Reviewed-by: Robert Bragg <robert@linux.intel.com>
Diffstat (limited to 'tests/conform/Makefile.am')
-rw-r--r--tests/conform/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/conform/Makefile.am b/tests/conform/Makefile.am
index a39070a4..b0f2a882 100644
--- a/tests/conform/Makefile.am
+++ b/tests/conform/Makefile.am
@@ -48,6 +48,7 @@ test_sources = \
test-primitive.c \
test-texture-3d.c \
test-sparse-pipeline.c \
+ test-read-alpha-texture.c \
$(NULL)
test_conformance_SOURCES = $(common_sources) $(test_sources)