summaryrefslogtreecommitdiff
path: root/tests/conform/Makefile.am
diff options
context:
space:
mode:
authorNeil Roberts <neil@linux.intel.com>2012-05-17 22:30:37 +0100
committerNeil Roberts <neil@linux.intel.com>2012-05-18 14:39:17 +0100
commita32eb76e16d7d76af2fe8a6ba9151d8826b58864 (patch)
tree106d65398e1b9cacbea7aa96c288ce7b91fce8c1 /tests/conform/Makefile.am
parent5064315678b496395e1d01f266f322d73e55e324 (diff)
downloadcogl-a32eb76e16d7d76af2fe8a6ba9151d8826b58864.tar.gz
Add a basic conformance test for eulers and quaternions
This adds some preliminary testing for eulers and quaternions. It mostly just tests the cogl_matrix_init_from_{quaternion,euler} functions as well as applying a euler or quaternion transformation to a framebuffer's modelview matrix. Reviewed-by: Robert Bragg <robert@linux.intel.com>
Diffstat (limited to 'tests/conform/Makefile.am')
-rw-r--r--tests/conform/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/conform/Makefile.am b/tests/conform/Makefile.am
index e57e6e98..4db891a9 100644
--- a/tests/conform/Makefile.am
+++ b/tests/conform/Makefile.am
@@ -55,6 +55,7 @@ test_sources = \
test-no-gl-header.c \
test-version.c \
test-gles2-context.c \
+ test-euler-quaternion.c \
$(NULL)
test_conformance_SOURCES = $(common_sources) $(test_sources)