summaryrefslogtreecommitdiff
path: root/tests/conform/Makefile.am
diff options
context:
space:
mode:
authorNeil Roberts <neil@linux.intel.com>2012-11-09 14:50:59 +0000
committerNeil Roberts <neil@linux.intel.com>2012-11-21 19:00:46 +0000
commit94b13b1abddfd8beef869433906661669634780e (patch)
tree1cb92c3ed7a8157c6faefad0c46b57d2ea49a23a /tests/conform/Makefile.am
parentf5fb9be70a92f751886a94da0b34e14252ed197e (diff)
downloadcogl-94b13b1abddfd8beef869433906661669634780e.tar.gz
Remove the pipeline layer user matrix
The pipeline layer user matrix is not used very often and the way it is currently implemented comes at a non-trivial cost. Any pipeline layer that requires the big state needs to have a CoglMatrix added to its state. The generated vertex shader will always multiply the coordinates by the matrix even if it is just the identity matrix. The same functionality can be achieved on programmable hardware using a shader snippet. The snippet hook for the texture coordinate transform is still available to make this convenient. If we later decide that this is a really useful feature for fixed function hardware then we can add it back in and try to make it work more efficiently. In the meantime however it seems like a good idea to get rid of the API now before Cogl 2.0 is released and the API becomes fixed. Reviewed-by: Robert Bragg <robert@linux.intel.com>
Diffstat (limited to 'tests/conform/Makefile.am')
-rw-r--r--tests/conform/Makefile.am1
1 files changed, 0 insertions, 1 deletions
diff --git a/tests/conform/Makefile.am b/tests/conform/Makefile.am
index b6430e25..3645f14e 100644
--- a/tests/conform/Makefile.am
+++ b/tests/conform/Makefile.am
@@ -35,7 +35,6 @@ test_sources = \
test-backface-culling.c \
test-just-vertex-shader.c \
test-path.c \
- test-pipeline-user-matrix.c \
test-pipeline-uniforms.c \
test-pixel-buffer.c \
test-premult.c \