summaryrefslogtreecommitdiff
path: root/tests/conform/Makefile.am
diff options
context:
space:
mode:
authorNeil Roberts <neil@linux.intel.com>2012-12-13 15:27:52 +0000
committerNeil Roberts <neil@linux.intel.com>2013-01-08 14:11:42 +0000
commit7ca01373efe908efc9f18f2cb7f4a51c274ef677 (patch)
treeb6935d51157784e83d80dc208a83192113477ef0 /tests/conform/Makefile.am
parent04a7aca9a98e84e43ac5559305a1358112902e30 (diff)
downloadcogl-7ca01373efe908efc9f18f2cb7f4a51c274ef677.tar.gz
Add a test for getting the component sizes from different fbs
This adds a test which creates two offscreen framebuffers, one with just an alpha component texture and the other will a full RGBA texture. The bit sizes of both framebuffers are then checked to verify that they either have or haven't got bits for the RGB components. The test currently fails because the framebuffer functions don't bind the framebuffer before querying so they just query whichever framebuffer happened to be used last. Reviewed-by: Robert Bragg <robert@linux.intel.com>
Diffstat (limited to 'tests/conform/Makefile.am')
-rw-r--r--tests/conform/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/conform/Makefile.am b/tests/conform/Makefile.am
index 013f29f9..9d6e516b 100644
--- a/tests/conform/Makefile.am
+++ b/tests/conform/Makefile.am
@@ -61,6 +61,7 @@ test_sources = \
test-wrap-rectangle-textures.c \
test-texture-get-set-data.c \
test-texture-mipmap-get-set.c \
+ test-framebuffer-get-bits.c \
$(NULL)
test_conformance_SOURCES = $(common_sources) $(test_sources)