summaryrefslogtreecommitdiff
path: root/tests/conform/Makefile.am
diff options
context:
space:
mode:
authorNeil Roberts <neil@linux.intel.com>2012-10-01 14:46:24 +0100
committerNeil Roberts <neil@linux.intel.com>2012-10-01 14:46:24 +0100
commit4ec04507bfaf2d61707dccfb59ac7326962ee741 (patch)
tree6b2eee79a5a7ae25fde9243c5443cbe21e7ccf95 /tests/conform/Makefile.am
parent3653c5b10058a3f79900eb2644cb30f4cf1ca47e (diff)
downloadcogl-4ec04507bfaf2d61707dccfb59ac7326962ee741.tar.gz
Add a simple conformance test for alpha testing
This adds a simple test which sets an alpha test on a pipeline and then renders a texture. It then verifies that the transparent parts of the texture aren't drawn. This is currently failing with the GL3 driver because GL3 requires the alpha test to be implemented in GLSL but the generated alpha test uniform is only updated for the GLES2 driver. Reviewed-by: Robert Bragg <robert@linux.intel.com>
Diffstat (limited to 'tests/conform/Makefile.am')
-rw-r--r--tests/conform/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/conform/Makefile.am b/tests/conform/Makefile.am
index 8eeffd0b..eab0b94e 100644
--- a/tests/conform/Makefile.am
+++ b/tests/conform/Makefile.am
@@ -56,6 +56,7 @@ test_sources = \
test-gles2-context.c \
test-euler-quaternion.c \
test-layer-remove.c \
+ test-alpha-test.c \
$(NULL)
test_conformance_SOURCES = $(common_sources) $(test_sources)