summaryrefslogtreecommitdiff
path: root/examples/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'examples/Makefile.am')
-rw-r--r--examples/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/examples/Makefile.am b/examples/Makefile.am
index 98e8e4f..b7959fb 100644
--- a/examples/Makefile.am
+++ b/examples/Makefile.am
@@ -9,8 +9,11 @@ noinst_PROGRAMS = \
gtk-clutter-test-actor \
gtk-clutter-window-test
-INCLUDES = -I$(srcdir) -I$(top_srcdir) -I$(top_builddir)/clutter-gtk
-
+AM_CPPFLAGS = \
+ -I$(srcdir) -I$(top_srcdir) -I$(top_builddir)/clutter-gtk \
+ -DGLIB_DISABLE_DEPRECATION_WARNINGS \
+ -DGDK_DISABLE_DEPRECATION_WARNINGS \
+ -DCLUTTER_DISABLE_DEPRECATION_WARNINGS
AM_CFLAGS = $(MAINTAINER_CFLAGS) $(CLUTTER_GTK_DEPS_CFLAGS)
common_deps = \