summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@linux.intel.com>2011-03-25 17:11:26 +0000
committerEmmanuele Bassi <ebassi@linux.intel.com>2011-03-25 17:11:26 +0000
commitf488e2522fa46aff57413bb6909104d35ddffc0b (patch)
tree0ce7726ac2de05d2942ee25c95c01c7ea224b37e /configure.ac
parent509f1dcab5bf0194f027a81cf246b18cc14d3958 (diff)
downloadclutter-gtk-f488e2522fa46aff57413bb6909104d35ddffc0b.tar.gz
build: Toggle deprecation when building from git
Deprecation guards for dependencies should only be turned on when building from Git, not from tarballs.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 14 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d371231..cb4b607 100644
--- a/configure.ac
+++ b/configure.ac
@@ -103,6 +103,17 @@ AC_SUBST(CLUTTER_LIBS)
AC_SUBST(GTK_CFLAGS)
AC_SUBST(GTK_LIBS)
+AS_IF([test clutter_gtk_release_status = 'git'],
+ [
+ CLUTTER_GTK_DEPRECATED_CFLAGS="-DG_DISABLE_DEPRECATED -DGDK_PIXBUF_DISABLE_DEPRECATED -DGDK_DISABLE_DEPRECATED -DGTK_DISABLE_DEPRECATED -DCOGL_DISABLE_DEPRECATED -DCLUTTER_DISABLE_DEPRECATED"
+ ],
+ [
+ CLUTTER_GTK_DEPRECATED_CFLAGS=""
+ ]
+)
+
+AC_SUBST(CLUTTER_GTK_DEPRECATED_CFLAGS)
+
dnl = Enable debug level ===================================================
m4_define([debug_default], [m4_if(m4_eval(clutter_gtk_minor % 2), [1], [yes], [minimum])])
@@ -153,6 +164,8 @@ AS_IF([test "x$enable_maintainer_flags" = "xyes" && test "x$GCC" = "xyes"],
]
)
+# strip leading spaces
+MAINTAINER_CFLAGS=${MAINTAINER_CFLAGS#* }
AC_SUBST(MAINTAINER_CFLAGS)
dnl = I18N =================================================================
@@ -215,6 +228,6 @@ echo ""
echo " Flavour: ${CLUTTER_GTK_FLAVOUR}"
echo " Debug level: ${enable_debug}"
echo " Documentation: ${enable_gtk_doc}"
-echo " Compiler flags: $MAINTAINER_CFLAGS"
+echo " Compiler flags: $CFLAGS $MAINTAINER_CFLAGS"
echo " Introspection data: ${enable_introspection}"
echo ""