summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@linux.intel.com>2009-04-14 17:16:41 +0100
committerEmmanuele Bassi <ebassi@linux.intel.com>2009-04-14 17:16:41 +0100
commit42da1d2aeb955eebba382f1a142e15d7273021c8 (patch)
treeb610bd90279b8f14c88ebdb0bc065fb5486c98f4 /Makefile.am
parent87ff77386cc502a0beed6bd1e1398c449e607e9f (diff)
downloadclutter-gtk-42da1d2aeb955eebba382f1a142e15d7273021c8.tar.gz
[build] Improve build environment
* De-crustify the configure.ac file by using AS_IF(), AS_CASE() and other useful macros * Update all the variables * Fix the pkg-config file Requires:, and expose the flavour and API version as variables * Fix the autogen.sh script * Use Shave to clean up the libtool and gcc incantations and make the output useful again
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 5211eca..57c2fd7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,7 +1,13 @@
+ACLOCAL_AMFLAGS = -I build/autotools
+
+V = @
+Q = $(V:1=)
+QUIET_GEN = $(Q:@=@echo ' GEN '$@;)
+
SUBDIRS = clutter-gtk doc examples
clutter-gtk-0.9.pc: clutter-gtk.pc
- @cp -f clutter-gtk.pc clutter-gtk-0.9.pc
+ $(QUIET_GEN)cp -f clutter-gtk.pc clutter-gtk-0.9.pc
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = clutter-gtk-0.9.pc
@@ -12,4 +18,4 @@ DISTCLEANFILES = clutter-gtk.pc
EXTRA_DIST = clutter-gtk.pc.in
-DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc
+DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc --enable-maintainer-flags