summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJosep Torra <n770galaxy@gmail.com>2011-09-21 14:15:11 +0200
committerDamien Lespiau <damien.lespiau@intel.com>2011-11-01 16:46:48 +0000
commit76d911db3b3e9ac8734b52dc41f83c1e528286a8 (patch)
tree79c27ccc7784aaaecb83b88cad80a18d1e505090 /configure.ac
parent12e6a977478d7db9ad078cbe1649713f05d67d65 (diff)
downloadclutter-gst-76d911db3b3e9ac8734b52dc41f83c1e528286a8.tar.gz
video-sink: Add a standalone GStreamer plugin
* Build the videosink as an independent .so library that can be deployed in GStreamer plugin directory. * Deprecate clutter_gst_video_sink_new() in favor of the usual GStreamer way of instanciating elements
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 508cf16..cbd9864 100644
--- a/configure.ac
+++ b/configure.ac
@@ -146,6 +146,17 @@ GST_MAJORMINOR=0.10
pkg_modules="gstreamer-$GST_MAJORMINOR >= $GSTREAMER_REQ_VERSION gstreamer-plugins-base-$GST_MAJORMINOR gstreamer-base-$GST_MAJORMINOR gstreamer-interfaces-$GST_MAJORMINOR gstreamer-video-$GST_MAJORMINOR gstreamer-audio-$GST_MAJORMINOR gstreamer-tag-$GST_MAJORMINOR"
PKG_CHECK_MODULES(GST, [$pkg_modules])
+dnl libs used by the plugin
+PKG_CHECK_MODULES([PLUGIN],
+ [clutter-1.0 >= $CLUTTER_REQ_VERSION
+ gstreamer-$GST_MAJORMINOR >= $GSTREAMER_REQ_VERSION
+ gstreamer-base-$GST_MAJORMINOR
+ gstreamer-interfaces-$GST_MAJORMINOR])
+
+dnl define location of gstreamer plugin directory
+plugindir="\$(libdir)/gstreamer-$GST_MAJORMINOR"
+AC_SUBST(plugindir)
+
dnl ========================================================================
dnl GL inclusion and link. We depend on GL for the single glGetIntegerv()
dnl call. The end goal is to get rid of it, but we can't just yet.