summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in29
1 files changed, 22 insertions, 7 deletions
diff --git a/configure.in b/configure.in
index 2cc94760e..fda4d67f6 100644
--- a/configure.in
+++ b/configure.in
@@ -1,23 +1,36 @@
-AC_INIT(index.theme.in)
-AM_INIT_AUTOMAKE(gnome-icon-theme, 2.8.0)
+# Process this file with autoconf to produce a configure script.
+AC_PREREQ(2.53)
-AM_MAINTAINER_MODE
+AC_INIT([gnome-icon-theme], [2.8.0],
+ [http://bugzilla.gnome.org/enter_bug.cgi?product=gnome-icon-theme])
+AC_CONFIG_SRCDIR(index.theme.in)
+
+AM_INIT_AUTOMAKE(AC_PACKAGE_NAME, AC_PACKAGE_VERSION)
AC_PROG_INTLTOOL
-ALL_LINGUAS="am ar az be bg bn bs ca cs cy da de el en_CA en_GB es et eu fa fi fr ga gl gu he hi hr hu id is it ja kn ko li lt lv mk ml mn ms nb ne nl nn no pa pl pt pt_BR ro ru sk sl sq sr sr@Latn sv ta th tk tr uk vi wa zh_CN zh_TW"
-GETTEXT_PACKAGE=gnome-icon-theme
+GETTEXT_PACKAGE="${PACKAGE}"
AC_SUBST(GETTEXT_PACKAGE)
+
+ALL_LINGUAS="am ar az be bg bn bs ca cs cy da de el en_CA en_GB es et eu fa fi fr ga gl gu he hi hr hu id is it ja kn ko li lt lv mk ml mn ms nb ne nl nn no pa pl pt pt_BR ro ru sk sl sq sr sr@Latn sv ta th tk tr uk vi wa zh_CN zh_TW"
AM_GLIB_GNU_GETTEXT
+# AM_GLIB_GNU_GETTEXT above subst. $DATADIRNAME
+# this is the directory where the *.{mo,gmo} files are installed
+localedir='${prefix}/${DATADIRNAME}/locale'
+AC_SUBST(localedir)
+
+# Workaround to make aclocal get the right flags
+AC_SUBST(ACLOCAL_AMFLAGS, "\${ACLOCAL_FLAGS}")
+
AC_ARG_ENABLE(hicolor-check,
AC_HELP_STRING([--disable-hicolor-check],
[disable the check for hicolor [default=no]]),
enable_hicolor_check=$enableval,
enable_hicolor_check=yes)
- AM_CONDITIONAL(ENABLE_HICOLOR_CHECK, test x$enable_hicolor_check = xyes)
+AM_CONDITIONAL(ENABLE_HICOLOR_CHECK, test x$enable_hicolor_check = xyes)
-AC_OUTPUT([
+AC_CONFIG_FILES([
Makefile
gnome-icon-theme.spec
gnome-icon-theme.pc
@@ -130,3 +143,5 @@ scalable/filesystems/Makefile
scalable/mimetypes/Makefile
po/Makefile.in
])
+
+AC_OUTPUT