summaryrefslogtreecommitdiff
path: root/build/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'build/Makefile.am')
-rw-r--r--build/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/build/Makefile.am b/build/Makefile.am
new file mode 100644
index 000000000..1073ed9b8
--- /dev/null
+++ b/build/Makefile.am
@@ -0,0 +1,30 @@
+themedir = $(datadir)/icons/THEME_NAME
+
+SUBDIRS = REAL_SUB_DIRS
+
+#THEME_IN_FILES = index.theme.in
+
+#%.theme: %.theme.in $(INTLTOOL_MERGE) $(wildcard $(top_srcdir)/po/*.po) ; $(INTLTOOL_MERGE) $(top_srcdir)/po $< $@ -d -u -c $(top_builddir)/po/.intltool-merge-cache
+
+theme_DATA = index.theme
+
+gtk_update_icon_cache = gtk-update-icon-cache -f -t "$(themedir)"
+
+install-data-hook:
+ @if test -z "$(DESTDIR)"; then \
+ echo "Updating Gtk icon cache."; \
+ $(gtk_update_icon_cache); \
+ else \
+ echo "*** Icon cache not updated. After install, run this:"; \
+ echo "*** $(gtk_update_icon_cache)"; \
+ fi
+
+
+EXTRA_DIST= \
+ index.theme
+
+# Extra clean files so that maintainer-clean removes *everything*
+MAINTAINERCLEANFILES = aclocal.m4 compile config.guess config.sub \
+ configure depcomp install-sh ltmain.sh \
+ Makefile.in missing config.h.in
+