summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorRodney Dawes <dobey@gnome.org>2010-01-03 17:32:56 -0500
committerRodney Dawes <dobey@gnome.org>2010-01-03 17:32:56 -0500
commit7a734d51716428f97e82b1ae8aa7a8b9bda64ef5 (patch)
tree204cf0be2046b20c0b4cafcc30fa1b7ca8ae9f73 /src/Makefile.am
parent2354277987b3112eb7f7ef9a9d0e1ad1a880d70e (diff)
downloadadwaita-icon-theme-7a734d51716428f97e82b1ae8aa7a8b9bda64ef5.tar.gz
Bring back a proper build system and theme generation
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am49
1 files changed, 49 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 000000000..2dd57499e
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,49 @@
+
+icon_in_files = $(shell SRCDIR="$(srcdir)"; for i in `find $$SRCDIR -name "*.svg"`; do printf "$$i "; done)
+icon_files = $(shell for i in `find $(top_builddir)/$(SVGOUTDIR) -name "*.png"`; do printf "$$i"; done)
+
+if ALLOW_RENDERING
+render-png: $(icon_in_files) Makefile
+ for file in $(icon_in_files); do \
+ for size in $(render_sizes); do \
+ $(ICONTOOL_RENDER) -s $$size -o $(top_builddir)/$(SVGOUTDIR) $$file >/dev/null; \
+ done; \
+ done
+
+else
+render-png: $(icon_in_files) Makefile
+ cp -a $(top_srcdir)/$(SVGOUTDIR) $(top_builddir)/$(SVGOUTDIR)
+
+endif
+
+$(render_sizes): Makefile
+
+render: render-png
+
+install-data-local:
+ for size in $(render_sizes); do \
+ for dir in `if [ -d $(top_srcdir)/$(SVGOUTDIR)/$$size ]; then find $(top_srcdir)/$(SVGOUTDIR)/$$size/* -type d; fi`; do \
+ for file in $(icon_files); do \
+ context="`dirname $$file`"; \
+ $(mkdir_p) $(DESTDIR)$(themedir)/$$size/$$context; \
+ $(install_sh_DATA) $(top_srcdir)/$(SVGOUTDIR)/$$size/$$file $(DESTDIR)$(themedir)/$$size/$$file; \
+ done; \
+ done; \
+ done
+
+uninstall-local:
+ for size in $(render_sizes); do \
+ for dir in `if [ -d $(top_srcdir)/$(SVGOUTDIR)/$$size ]; then find $(top_srcdir)/$(SVGOUTDIR)/$$size/* -type d; fi`; do \
+ for file in $(icon_files); do \
+ rm -f $(DESTDIR)$(themedir)/$$size/$$file; \
+ done; \
+ done; \
+ done
+
+EXTRA_DIST = \
+ $(icon_in_files)
+
+
+MAINTAINERCLEANFILES = \
+ Makefile.in \
+ $(icon_cache)