summaryrefslogtreecommitdiff
path: root/scalable/emblems/Makefile.am
diff options
context:
space:
mode:
authorRodney Dawes <dobey@novell.com>2006-11-09 14:09:28 +0000
committerRodney Dawes <dobey@src.gnome.org>2006-11-09 14:09:28 +0000
commita84dd8694337303f342d543293b9c09a4f735484 (patch)
tree25b12bce5a31212aff7cf45ec732dabc011066d9 /scalable/emblems/Makefile.am
parentdc8dbd4638183d32f53aacea3a3bbc1bef1c3d52 (diff)
downloadadwaita-icon-theme-a84dd8694337303f342d543293b9c09a4f735484.tar.gz
Add nifty make check rule to check that all of the icons are listed in the
2006-11-09 Rodney Dawes <dobey@novell.com> * */*/Makefile.am: Add nifty make check rule to check that all of the icons are listed in the Makefile.am to help prevent missing icons
Diffstat (limited to 'scalable/emblems/Makefile.am')
-rw-r--r--scalable/emblems/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/scalable/emblems/Makefile.am b/scalable/emblems/Makefile.am
index 17f193b40..e552ba018 100644
--- a/scalable/emblems/Makefile.am
+++ b/scalable/emblems/Makefile.am
@@ -47,3 +47,22 @@ CLEANFILES = $(icons_DATA)
install-data-local: install-iconsDATA install-svgDATA
(cd $(DESTDIR)$(themedir)/$(size) && $(ICONMAP) -c $(context))
+
+check:
+ if test -r CVS/Entries; then \
+ for icon in *.svg; do \
+ if grep $$icon CVS/Entries > /dev/null; then \
+ if ! grep $$icon Makefile > /dev/null; then \
+ echo "Missing $$icon in Makefile.am"; \
+ exit 1; \
+ fi; \
+ fi; \
+ done; \
+ else \
+ for icon in *.svg; do \
+ if ! grep $$icon Makefile > /dev/null; then \
+ echo "Missing $$icon in Makefile.am"; \
+ exit 1; \
+ fi; \
+ done; \
+ fi