summaryrefslogtreecommitdiff
path: root/plugins/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/Makefile.am')
-rw-r--r--plugins/Makefile.am15
1 files changed, 12 insertions, 3 deletions
diff --git a/plugins/Makefile.am b/plugins/Makefile.am
index 027ae162..ef82aa0e 100644
--- a/plugins/Makefile.am
+++ b/plugins/Makefile.am
@@ -1,7 +1,6 @@
NULL =
-SUBDIRS = \
- common \
+enabled_plugins = \
a11y-keyboard \
background \
clipboard \
@@ -12,10 +11,20 @@ SUBDIRS = \
keyboard \
media-keys \
mouse \
- smartcard \
sound \
typing-break \
xrandr \
xrdb \
xsettings \
$(NULL)
+
+disabled_plugins = $(NULL)
+
+if SMARTCARD_SUPPORT
+enabled_plugins += smartcard
+else
+disabled_plugins += smartcard
+endif
+
+SUBDIRS = common $(enabled_plugins)
+DIST_SUBDIRS = $(SUBDIRS) $(disabled_plugins)