summaryrefslogtreecommitdiff
path: root/plugins/smartcard/Makefile.am
diff options
context:
space:
mode:
authorRay Strode <rstrode@redhat.com>2010-04-19 23:02:30 -0400
committerRay Strode <rstrode@redhat.com>2010-04-23 16:41:01 -0400
commit6c87af2623f611de55730fe856c8a5abd3991277 (patch)
tree2558265524c0bfbed0c73f8712f5d7b5815ed20b /plugins/smartcard/Makefile.am
parentc246fd81185560e85bc090d523243b868078bf9a (diff)
downloadgnome-settings-daemon-6c87af2623f611de55730fe856c8a5abd3991277.tar.gz
Add smartcard plugin
This plugin listens for smartcard insertion and removal events and then locks the screen or forces a log out (depending on gconf) when the card used for login is removed.
Diffstat (limited to 'plugins/smartcard/Makefile.am')
-rw-r--r--plugins/smartcard/Makefile.am49
1 files changed, 49 insertions, 0 deletions
diff --git a/plugins/smartcard/Makefile.am b/plugins/smartcard/Makefile.am
new file mode 100644
index 00000000..97468cde
--- /dev/null
+++ b/plugins/smartcard/Makefile.am
@@ -0,0 +1,49 @@
+if SMARTCARD_SUPPORT
+plugin_LTLIBRARIES = \
+ libsmartcard.la
+
+libsmartcard_la_SOURCES = \
+ gsd-smartcard-plugin.h \
+ gsd-smartcard-plugin.c \
+ gsd-smartcard.h \
+ gsd-smartcard.c \
+ gsd-smartcard-manager.h \
+ gsd-smartcard-manager.c
+
+libsmartcard_la_CPPFLAGS = \
+ -I$(top_srcdir)/gnome-settings-daemon \
+ -DGNOME_SETTINGS_LOCALEDIR=\""$(datadir)/locale"\" \
+ -DSYSCONFDIR=\""$(sysconfdir)"\" \
+ -DLIBDIR=\""$(libdir)"\" \
+ -DGSD_SMARTCARD_MANAGER_NSS_DB=\""$(NSS_DATABASE)"\" \
+ $(AM_CPPFLAGS)
+
+libsmartcard_la_CFLAGS = \
+ $(SETTINGS_PLUGIN_CFLAGS) \
+ $(GNOME_CFLAGS) \
+ $(NSS_CFLAGS) \
+ $(AM_CFLAGS)
+
+libsmartcard_la_LDFLAGS = \
+ $(GSD_PLUGIN_LDFLAGS)
+
+libsmartcard_la_LIBADD = \
+ $(SETTINGS_PLUGIN_LIBS) \
+ $(NSS_LIBS)
+
+plugin_in_files = \
+ smartcard.gnome-settings-plugin.in
+
+plugin_DATA = $(plugin_in_files:.gnome-settings-plugin.in=.gnome-settings-plugin)
+
+EXTRA_DIST = \
+ $(plugin_in_files)
+
+CLEANFILES = \
+ $(plugin_DATA)
+
+DISTCLEANFILES = \
+ $(plugin_DATA)
+
+@GSD_INTLTOOL_PLUGIN_RULE@
+endif