summaryrefslogtreecommitdiff
path: root/plugins/smartcard/Makefile.am
diff options
context:
space:
mode:
authorRay Strode <rstrode@redhat.com>2013-05-28 09:20:57 -0400
committerRay Strode <rstrode@redhat.com>2013-05-28 09:20:57 -0400
commit60621c4ae60d3f722972b4c1a907773caa6dd041 (patch)
tree52cf7835ee04267a83686493c5a7f905a4ecd3d6 /plugins/smartcard/Makefile.am
parent1d4dcea5a1dca9ef15fefd9fd179650a43baf58c (diff)
downloadgnome-settings-daemon-60621c4ae60d3f722972b4c1a907773caa6dd041.tar.gz
smartcard: drop old implementation
It's going to be substantially rewritten, so drop the old code to avoid a confusing diff when the new stuff lands.
Diffstat (limited to 'plugins/smartcard/Makefile.am')
-rw-r--r--plugins/smartcard/Makefile.am75
1 files changed, 0 insertions, 75 deletions
diff --git a/plugins/smartcard/Makefile.am b/plugins/smartcard/Makefile.am
deleted file mode 100644
index e2a0addb..00000000
--- a/plugins/smartcard/Makefile.am
+++ /dev/null
@@ -1,75 +0,0 @@
-plugin_name = smartcard
-
-libexec_PROGRAMS = gsd-test-smartcard
-
-gsd_test_smartcard_SOURCES = \
- gsd-smartcard-manager.h \
- gsd-smartcard-manager.c \
- gsd-smartcard.h \
- gsd-smartcard.c \
- test-smartcard.c
-
-gsd_test_smartcard_CFLAGS = \
- -I$(top_srcdir)/gnome-settings-daemon \
- -I$(top_srcdir)/plugins/common \
- -DSYSCONFDIR=\""$(sysconfdir)"\" \
- -DLIBDIR=\""$(libdir)"\" \
- -DGNOME_SETTINGS_LOCALEDIR=\""$(datadir)/locale"\" \
- $(NSS_CFLAGS) \
- $(PLUGIN_CFLAGS) \
- $(SETTINGS_PLUGIN_CFLAGS) \
- $(AM_CFLAGS)
-
-gsd_test_smartcard_LDADD = \
- $(top_builddir)/gnome-settings-daemon/libgsd.la \
- $(top_builddir)/plugins/common/libcommon.la \
- $(NSS_LIBS) \
- $(SETTINGS_PLUGIN_LIBS)
-
-plugin_LTLIBRARIES = \
- libsmartcard.la
-
-libsmartcard_la_SOURCES = \
- gsd-smartcard-plugin.h \
- gsd-smartcard-plugin.c \
- gsd-smartcard.h \
- gsd-smartcard.c \
- gsd-smartcard-manager.h \
- gsd-smartcard-manager.c
-
-libsmartcard_la_CPPFLAGS = \
- -I$(top_srcdir)/gnome-settings-daemon \
- -DGNOME_SETTINGS_LOCALEDIR=\""$(datadir)/locale"\" \
- -DSYSCONFDIR=\""$(sysconfdir)"\" \
- -DLIBDIR=\""$(libdir)"\" \
- -DGSD_SMARTCARD_MANAGER_NSS_DB=\""$(NSS_DATABASE)"\" \
- $(AM_CPPFLAGS)
-
-libsmartcard_la_CFLAGS = \
- $(PLUGIN_CFLAGS) \
- $(SETTINGS_PLUGIN_CFLAGS) \
- $(NSS_CFLAGS) \
- $(AM_CFLAGS)
-
-libsmartcard_la_LDFLAGS = \
- $(GSD_PLUGIN_LDFLAGS)
-
-libsmartcard_la_LIBADD = \
- $(SETTINGS_PLUGIN_LIBS) \
- $(NSS_LIBS)
-
-@GSD_INTLTOOL_PLUGIN_RULE@
-
-plugin_in_files = \
- smartcard.gnome-settings-plugin.in
-
-plugin_DATA = $(plugin_in_files:.gnome-settings-plugin.in=.gnome-settings-plugin)
-
-EXTRA_DIST = \
- $(plugin_in_files)
-
-CLEANFILES = \
- $(plugin_DATA)
-
-DISTCLEANFILES = \
- $(plugin_DATA)