summaryrefslogtreecommitdiff
path: root/plugins/media-keys/Makefile.am
diff options
context:
space:
mode:
authorLars Uebernickel <lars.uebernickel@canonical.com>2013-06-14 16:05:32 +0100
committerBastien Nocera <hadess@hadess.net>2013-08-01 09:47:34 +0200
commit0df8545f5a92cdcedce0d9cafdc14eeb524dc4c5 (patch)
treea7120db682a867c2e3f35e0d25b2c8feeba9a89b /plugins/media-keys/Makefile.am
parent9dd8a7cde4a2e282c92e7f7567d48560387301f1 (diff)
downloadgnome-settings-daemon-0df8545f5a92cdcedce0d9cafdc14eeb524dc4c5.tar.gz
media-keys: Add bus namespace watching
This adds a bus namespace watching helper, mimicking the g_bus_watch_name() API but watching name prefixes instead of bus names. https://bugzilla.gnome.org/show_bug.cgi?id=697810
Diffstat (limited to 'plugins/media-keys/Makefile.am')
-rw-r--r--plugins/media-keys/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/plugins/media-keys/Makefile.am b/plugins/media-keys/Makefile.am
index 51e99dbc..6b82014c 100644
--- a/plugins/media-keys/Makefile.am
+++ b/plugins/media-keys/Makefile.am
@@ -36,6 +36,8 @@ libmedia_keys_la_SOURCES = \
gsd-screenshot-utils.c \
shortcuts-list.h \
shell-keybinding-modes.h \
+ bus-watch-namespace.c \
+ bus-watch-namespace.h \
$(BUILT_SOURCES) \
$(NULL)
@@ -78,6 +80,8 @@ gsd_test_media_keys_SOURCES = \
gsd-media-keys-manager.h \
gsd-screenshot-utils.h \
gsd-screenshot-utils.c \
+ bus-watch-namespace.c \
+ bus-watch-namespace.h \
test-media-keys.c \
$(BUILT_SOURCES) \
$(NULL)