summaryrefslogtreecommitdiff
path: root/plugins/Makefile.am
diff options
context:
space:
mode:
authorRay Strode <rstrode@redhat.com>2010-06-08 17:56:22 -0400
committerRay Strode <rstrode@redhat.com>2016-11-07 13:11:39 -0500
commit6fb09da7f2d5334c5fe93f0e698034844ca0aab7 (patch)
treeeb3148ca5f6874f71248d0dec753fc762a39d33f /plugins/Makefile.am
parentb4a271f9718d6c3f209b32e98a0a982c8a8c8a40 (diff)
downloadgnome-settings-daemon-6fb09da7f2d5334c5fe93f0e698034844ca0aab7.tar.gz
Fix build for --disable-smartcard-support
commit 4b334ddf6c53ce795063d44746a9a2d90fea85ff broke the build for --disable-smartcard-users. This commit fixes that. Based on a patch from William Jon McCann <william.jon.mccann@gmail.com> https://bugzilla.gnome.org/show_bug.cgi?id=617748
Diffstat (limited to 'plugins/Makefile.am')
-rw-r--r--plugins/Makefile.am15
1 files changed, 12 insertions, 3 deletions
diff --git a/plugins/Makefile.am b/plugins/Makefile.am
index 027ae162..ef82aa0e 100644
--- a/plugins/Makefile.am
+++ b/plugins/Makefile.am
@@ -1,7 +1,6 @@
NULL =
-SUBDIRS = \
- common \
+enabled_plugins = \
a11y-keyboard \
background \
clipboard \
@@ -12,10 +11,20 @@ SUBDIRS = \
keyboard \
media-keys \
mouse \
- smartcard \
sound \
typing-break \
xrandr \
xrdb \
xsettings \
$(NULL)
+
+disabled_plugins = $(NULL)
+
+if SMARTCARD_SUPPORT
+enabled_plugins += smartcard
+else
+disabled_plugins += smartcard
+endif
+
+SUBDIRS = common $(enabled_plugins)
+DIST_SUBDIRS = $(SUBDIRS) $(disabled_plugins)