summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2018-08-29 10:06:40 +0200
committerGuido Günther <agx@sigxcpu.org>2019-08-02 16:15:52 +0200
commit94baaea843db9d92e5f2ba1b99516f0bac4a6feb (patch)
tree39d958d9efc695b371c4df9e7fbba3f2c08bc2ed /meson.build
parent62981b3c18baa1e34060062c3ae8f1c1b3064691 (diff)
downloadgnome-settings-daemon-94baaea843db9d92e5f2ba1b99516f0bac4a6feb.tar.gz
Initial wwan plugin
Heavily based on code from nm-applet. Follow-Ups: - Allow to store SIM in keyring - Handle PUKs? (or do that in g-c-c)
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index f56984d5..1cf16b3a 100644
--- a/meson.build
+++ b/meson.build
@@ -191,6 +191,13 @@ if enable_rfkill
endif
endif
+# wwan
+enable_wwan = get_option('wwan')
+if enable_wwan
+ gcr_base_dep = dependency('gcr-base-3', version: '>= 3.7.5')
+ mm_glib_dep = dependency('mm-glib', version: '>= 1.0')
+endif
+
# Sharing plugin
enable_network_manager = get_option('network_manager')
assert(enable_network_manager or not host_is_linux, 'NetworkManager support is not optional on Linux platforms')