summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorBenjamin Berg <bberg@redhat.com>2018-01-10 20:09:30 +0100
committerBenjamin Berg <benjamin@sipsolutions.net>2018-09-27 07:12:22 +0000
commit8152a20bae04c84f028b1eae04f42f4c27215da8 (patch)
treea6c7a04a357cef75602ef4945279c6fcab0f3df0 /meson.build
parent74dcf3f4e8ecf49d6da8030aba35e3555d0aca01 (diff)
downloadgnome-settings-daemon-8152a20bae04c84f028b1eae04f42f4c27215da8.tar.gz
power: Refactor backlight handling to be asynchronous
Writing the backlight value can take quite long, in particular when we also get the overhead of starting up the helper process for writing. Add code to handle the writing asynchronously and compress multiple set actions into one write. The notification of the change only happens once all of the queued up set operations have finished. A trivial bugfix included is that the OSD display is again shown only on the affected (internal) screen. Note that a possible further improvement would be to just run the backlight helper once and communicate with it through stdin or some other methods, avoiding the overhead of starting it up all the time. There are a few minor disadvantages with this approach though, see comment #16 and following for more information. https://bugzilla.gnome.org/show_bug.cgi?id=758413
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 796da940..47cf3722 100644
--- a/meson.build
+++ b/meson.build
@@ -82,6 +82,7 @@ endif
add_project_arguments(common_flags + compiler_flags, language: 'c')
+glib_dep = dependency('glib-2.0', version: '>= 2.56')
colord_dep = dependency('colord', version: '>= 1.0.2')
geocode_glib_dep = dependency('geocode-glib-1.0', version: '>= 3.10.0')
gio_dep = dependency('gio-2.0', version: '>= 2.53.0')