summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMarvin Schmidt <marv@exherbo.org>2018-06-22 20:12:50 +0200
committerMarvin Schmidt <marv@exherbo.org>2018-09-15 12:40:15 +0200
commit51088a9c27d713bbe63359b865603c833eb5a930 (patch)
tree6dc94e6707ea71c7ab97995ae381c7a63f90e465 /meson.build
parent9173891a910268a6bff9c57f270eefad60fbef3b (diff)
downloadgnome-settings-daemon-51088a9c27d713bbe63359b865603c833eb5a930.tar.gz
build: Fix build when wayland support is disabled
The udev based device manager used for wayland environments was built based on the state of the gudev option instead of the wayland option. This resulted in an build error when building with `-Dwayland=false` since the gdk/gdkwayland.h header file is not present on systems without gdk-wayland-3.0. This patch puts the compilation of the udev based device manager behind the wayland option and the gdk-wayland-3.0 dependency
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 785094dd..247d1718 100644
--- a/meson.build
+++ b/meson.build
@@ -125,11 +125,12 @@ if enable_gudev
endif
config_h.set10('HAVE_GUDEV', enable_gudev)
-# Check for libwayland-client
+# Check for wayland dependencies
enable_wayland = get_option('wayland')
if enable_wayland
assert(enable_gudev, 'GUDev support is required for wayland support.')
wayland_client_dep = dependency('wayland-client')
+ wayland_gdk_dep = dependency('gdk-wayland-3.0')
endif
config_h.set10('HAVE_WAYLAND', enable_wayland)