summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRui Matos <tiagomatos@gmail.com>2012-04-16 18:22:14 +0200
committerBastien Nocera <hadess@hadess.net>2012-06-01 18:32:25 +0100
commitb6e011ad16311e2985aa523cf9bceef74168f95e (patch)
tree572ce1452af9f6bc54cd2dfba37ccc51fc1a5667 /configure.ac
parent6eaf9b2aec37571047eafa87e8c89c65eed54de6 (diff)
downloadgnome-settings-daemon-b6e011ad16311e2985aa523cf9bceef74168f95e.tar.gz
keyboard: Apply XKB layouts ourselves and stop relying on libgnomekbd
libgnomekbd/xklavier aren't a good fit to have the keyboard input story that we want since they rely on implementation details of the XKB protocol to provide users with a means to switch keyboard layouts. Of note here is a) their reliance on XKB groups, of which there can be only up to 4, to specify the layouts the user is able to switch between and b) their reliance on XKB options to specify the keybinding to switch layouts which is a restricted set and falls outside the regular GNOME desktop wide keybindings management as it's implemented entirely on the X server side. This commit introduces the use of a shared GSettings schema from gsettings-desktop-schemas which will be the storage for our new concept of "input sources". We only handle XKB layouts as input sources for now. We do it using roughly the same method that setxkbmap(1) uses which should allow the users that want to specify their own XKB features (except layout) to still do so outside of GNOME (e.g. in a session startup script). https://bugzilla.gnome.org/show_bug.cgi?id=676102
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 2 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 5f7bbcbf..0d9ee326 100644
--- a/configure.ac
+++ b/configure.ac
@@ -47,7 +47,7 @@ GLIB_REQUIRED_VERSION=2.31.0
GTK_REQUIRED_VERSION=3.3.18
GCONF_REQUIRED_VERSION=2.6.1
GIO_REQUIRED_VERSION=2.26.0
-GNOME_DESKTOP_REQUIRED_VERSION=3.3.92
+GNOME_DESKTOP_REQUIRED_VERSION=3.5.1
LIBNOTIFY_REQUIRED_VERSION=0.7.3
UPOWER_GLIB_REQUIRED_VERSION=0.9.1
PA_REQUIRED_VERSION=0.9.16
@@ -175,8 +175,7 @@ dnl ---------------------------------------------------------------------------
dnl - Keyboard plugin stuff
dnl ---------------------------------------------------------------------------
-LIBGNOMEKBD_REQUIRED=3.5.1
-PKG_CHECK_MODULES(KEYBOARD, [libgnomekbdui >= $LIBGNOMEKBD_REQUIRED libgnomekbd >= $LIBGNOMEKBD_REQUIRED libxklavier >= 5.0 kbproto])
+PKG_CHECK_MODULES(KEYBOARD, gnome-desktop-3.0 >= $GNOME_DESKTOP_REQUIRED_VERSION)
dnl ---------------------------------------------------------------------------
dnl - Housekeeping plugin stuff