summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMartin Pitt <martinpitt@gnome.org>2013-01-04 17:33:08 +0100
committerBastien Nocera <hadess@hadess.net>2013-01-07 10:41:18 +0100
commit2fbb4040219bf564ac4dc9e2ec383c1522d0445b (patch)
tree831426a2b63abf9b3af03f2b1f839a7ac9434e9a /Makefile.am
parent0e6bbd5abc6211fab9bb53a8c3b64aa01a4dcabc (diff)
downloadgnome-settings-daemon-2fbb4040219bf564ac4dc9e2ec383c1522d0445b.tar.gz
Add support for plugin tests
Add a GSDTestCase Python class (tests/gsdtestcase.py) which provides functionality for writing daemon and plugin tests: * Launch temporary private session and system D-BUSes to avoid disturbing the currently running system and being able to use mock D-BUS services. * Run a minimal gnome-session to ensure plugins can check the session idle status, register to the session, etc. * Configure temporary local XDG directories to avoid disturbing the user's real settings and files. * Run a mock notification daemon to avoid showing notifications produced by test cases, using python-dbusmock. (http://pypi.python.org/pypi/python-dbusmock) * Provide API to start/stop a mock logind, using python-dbusmock. * Provide API to reste the session idle timer, using a small "shiftkey" helper program that sends a "left shift key" event through XTest. If any of the required dependencies (gnome-session, dbusmock, pygobject) is not present, it exits with an error message and exit code 0, to avoid breaking tests in minimal build environments. https://bugzilla.gnome.org/show_bug.cgi?id=685951
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 6bb3d580..e7ae0305 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -5,6 +5,7 @@ SUBDIRS = \
plugins \
data \
po \
+ tests \
$(NULL)
if ENABLE_MAN