summaryrefslogtreecommitdiff
path: root/tool/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tool/Makefile.am')
-rw-r--r--tool/Makefile.am19
1 files changed, 10 insertions, 9 deletions
diff --git a/tool/Makefile.am b/tool/Makefile.am
index 0bc39129..3efac5ee 100644
--- a/tool/Makefile.am
+++ b/tool/Makefile.am
@@ -1,5 +1,5 @@
bin_PROGRAMS= \
- gnome-keyring-@GCR_MAJOR@
+ gnome-keyring-@GKR_MAJOR@
INCLUDES= \
-I$(top_srcdir) \
@@ -7,28 +7,29 @@ INCLUDES= \
$(GTK_CFLAGS) \
$(GOBJECT_CFLAGS) \
$(GLIB_CFLAGS) \
+ $(GCK_CFLAGS) \
+ $(GCR_CFLAGS) \
-DGCK_API_SUBJECT_TO_CHANGE
-gnome_keyring_@GCR_MAJOR@_SOURCES = \
+gnome_keyring_@GKR_MAJOR@_SOURCES = \
gkr-tool.c gkr-tool.h \
gkr-tool-import.c \
gkr-tool-trust.c \
gkr-tool-version.c
-gnome_keyring_@GCR_MAJOR@_CFLAGS = \
+gnome_keyring_@GKR_MAJOR@_CFLAGS = \
-DGCR_API_SUBJECT_TO_CHANGE \
-DGNOMELOCALEDIR=\""$(datadir)/locale"\"
-gnome_keyring_@GCR_MAJOR@_LDADD = \
- $(top_builddir)/gcr/libgcr-base-@GCR_MAJOR@.la \
- $(top_builddir)/gcr/libgcr-@GCR_MAJOR@.la \
+gnome_keyring_@GKR_MAJOR@_LDADD = \
$(top_builddir)/egg/libegg.la \
- $(top_builddir)/gck/libgck-@GCK_MAJOR@.la \
+ $(GCK_LIBS) \
+ $(GCR_LIBS) \
$(GTHREAD_LIBS) \
$(GTK_LIBS) \
$(GCRYPT_LIBS) \
$(DAEMON_LIBS)
-# Install a link from gnome-keyring > gnome-keyring-@GCR_MAJOR@ to maintain compatibility
+# Install a link from gnome-keyring > gnome-keyring-@GKR_MAJOR@ to maintain compatibility
install-exec-hook:
- @test -e "$(DESTDIR)$(bindir)/gnome-keyring" || (cd $(DESTDIR)$(bindir) && $(LN_S) gnome-keyring-@GCR_MAJOR@ gnome-keyring)
+ @test -e "$(DESTDIR)$(bindir)/gnome-keyring" || (cd $(DESTDIR)$(bindir) && $(LN_S) gnome-keyring-@GKR_MAJOR@ gnome-keyring)