summaryrefslogtreecommitdiff
path: root/support/Makefile.am
diff options
context:
space:
mode:
authorMartin Baulig <martin@home-of-linux.org>1998-06-08 00:12:50 +0000
committerMartin Baulig <martin@src.gnome.org>1998-06-08 00:12:50 +0000
commit8fa4243225708945637ab1d4fb868e42d9f9ba6a (patch)
tree6f9d711cf3cd3726d5903b76e7d49abc6ae8da27 /support/Makefile.am
parentdc380112eeed5fa0edcf98191ea3edff04a5a819 (diff)
downloadgnome-common-8fa4243225708945637ab1d4fb868e42d9f9ba6a.tar.gz
When cross-compiling, this is build using `$(build_CC)' because it needs
1998-06-08 Martin Baulig <martin@home-of-linux.org> * Makefile.am (gnomesupport-h): When cross-compiling, this is build using `$(build_CC)' because it needs to run on the build system. Look at gnome-libs/configure.in to see how to get `build_CC'. svn path=/trunk/; revision=242
Diffstat (limited to 'support/Makefile.am')
-rw-r--r--support/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/support/Makefile.am b/support/Makefile.am
index 78639bc..394492d 100644
--- a/support/Makefile.am
+++ b/support/Makefile.am
@@ -5,6 +5,10 @@ supportincludedir = $(pkglibdir)/include
if BUILD_GNOME_SUPPORT
INCLUDES = -D_GNU_SOURCE
+if CROSS_COMPILING
+CC = $(build_CC)
+endif
+
lib_LTLIBRARIES = libgnomesupport.la
supportinclude_HEADERS = gnome-argp.h getopt.h long-options.h argp.h