summaryrefslogtreecommitdiff
path: root/support/Makefile.am
diff options
context:
space:
mode:
authorRaja R Harinath <harinath@src.gnome.org>1998-04-12 21:07:55 +0000
committerRaja R Harinath <harinath@src.gnome.org>1998-04-12 21:07:55 +0000
commit41085eb1a0a8772f982d2fb9f2adcf75baec8d13 (patch)
tree95e748f18b65118d88ff6c3a0f9e1f81af1ae157 /support/Makefile.am
parenta7770e415ad2ae3028d31afd6956e360f2b10c58 (diff)
downloadgnome-common-41085eb1a0a8772f982d2fb9f2adcf75baec8d13.tar.gz
Is now $(pkglibdir)/include. `gnomesupport.h' is a generated file
* Makefile.am (supportincludedir): Is now $(pkglibdir)/include. `gnomesupport.h' is a generated file dependent on the configure process. So, this seems a good place. The rest of the headers are also here just because I'm too lazy to maintain two separate include directories to search in for `libgnomesupport' stuff ;-) (supportinclude_DATA): New var. Has `gnomesupport.h'. (BUILT_SOURCES): Generate `gnomesupport.h'. * gnomesupport-h.c: New file. Used to generate `gnomesupport.h', which contains prototypes for many of the functions in `libgnomesupport'. This method is used to ensure that prototypes appear only for those functions that are provided by `libgnomesupport'. * scandir.c (alphasort): New utility function. svn path=/trunk/; revision=190
Diffstat (limited to 'support/Makefile.am')
-rw-r--r--support/Makefile.am14
1 files changed, 13 insertions, 1 deletions
diff --git a/support/Makefile.am b/support/Makefile.am
index 7876a80..7dfc945 100644
--- a/support/Makefile.am
+++ b/support/Makefile.am
@@ -1,6 +1,6 @@
## Process this file with automake to produce Makefile.in.
-supportincludedir = $(includedir)/libgnomesupport
+supportincludedir = $(pkglibdir)/include
if BUILD_GNOME_SUPPORT
@@ -8,6 +8,10 @@ lib_LTLIBRARIES = libgnomesupport.la
supportinclude_HEADERS = gnome-argp.h getopt.h long-options.h argp.h
+# it is in _DATA since we don't want `gnomesupport.h' to be part of
+# the distributed `.tar.gz' file
+supportinclude_DATA = gnomesupport.h
+
# These are internal headers: they are used only when compiling and
# should not be installed
noinst_HEADERS = argp-fmtstream.h argp-namefrob.h
@@ -16,6 +20,14 @@ libgnomesupport_la_SOURCES = long-options.c gnome-argp.c
libgnomesupport_la_LIBADD = @LTLIBOBJS@
libgnomesupport_la_LDFLAGS = -version-info 0:0:0
+noinst_PROGRAMS = gnomesupport-h
+
+BUILT_SOURCES = gnomesupport.h
+
+gnomesupport.h: gnomesupport-h
+ ./gnomesupport-h > gnomesupport.h-new && \
+ mv gnomesupport.h-new gnomesupport.h
+
endif
EXTRA_DIST = argp-test.c argp.texi