summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am20
1 files changed, 10 insertions, 10 deletions
diff --git a/Makefile.am b/Makefile.am
index 3317a14de..16594efc3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -58,21 +58,21 @@
# GMP -version-info
# release libgmp libmp
# 2.0.x - -
-# 3.0 3:0:1 3:0:1
+# 3.0 3:0:0 3:0:0
#
#
-# Starting at 3:0:1 is a slight abuse of the versioning system, but it makes
-# libtool produce libgmp.so.2.1.0 on GNU/Linux, matching unofficial shared
-# libraries built from gmp 2.0.x, with which gmp 3 is upwardly compatible.
-# Pretend gmp 2 was 2:0:0.
+# Starting at 3:0:0 is a slight abuse of the versioning system, but it
+# ensures we're past soname libgmp.so.2, which is what has been used on
+# Debian GNU/Linux packages of gmp 2. Pretend gmp 2 was 2:0:0, so the
+# interface changes for gmp 3 mean 3:0:0 is right.
-LIBGMP_LT_CURRENT = 3
+LIBGMP_LT_CURRENT = 3
LIBGMP_LT_REVISION = 0
-LIBGMP_LT_AGE = 1
+LIBGMP_LT_AGE = 0
-LIBMP_LT_CURRENT = 3
+LIBMP_LT_CURRENT = 3
LIBMP_LT_REVISION = 0
-LIBMP_LT_AGE = 1
+LIBMP_LT_AGE = 0
AUTOMAKE_OPTIONS = gnu check-news no-dependencies
@@ -84,7 +84,7 @@ EXTRA_HEADERS = mp.h
lib_LTLIBRARIES = libgmp.la $(MPBSD_LTLIBRARIES_OPTION)
-EXTRA_DIST = gmp-impl.h longlong.h stack-alloc.h urandom.h
+EXTRA_DIST = gmp-impl.h longlong.h stack-alloc.h urandom.h projects
DISTCLEANFILES = asm-syntax.h config.m4 @gmp_srclinks@