summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorKevin Ryde <user42@zip.com.au>2002-03-11 01:30:33 +0100
committerKevin Ryde <user42@zip.com.au>2002-03-11 01:30:33 +0100
commitfb6d99438cebd974b2aa683e6b24ccd1e74cb343 (patch)
tree568759aaae41840859e5b15c90e4684a708a0817 /configure.in
parent33d3296599d9fd65b3c2e10c461cd2b1ef54b0fc (diff)
downloadgmp-fb6d99438cebd974b2aa683e6b24ccd1e74cb343.tar.gz
* configure.in (LIBC211): New AC_DEFINE, for mpfr.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 489e8ff11..ca01a1154 100644
--- a/configure.in
+++ b/configure.in
@@ -1907,6 +1907,17 @@ AC_SUBST(mpn_objs_in_libgmp)
AC_SUBST(gmp_srclinks)
+# Configs for mpfr.
+#
+if test $enable_mpfr = yes; then
+ AC_CHECK_FUNCS(__setfpucw)
+ if test "$ac_cv_func___setfpucw" != yes; then
+ AC_DEFINE(LIBC211,1,
+ [Define if you don't have `__setfpucw' (eg. glibc 2.1 and up)])
+ fi
+fi
+
+
# A recompiled sqr_basecase for use in the tune program, if necessary.
TUNE_SQR_OBJ=
test -d tune || mkdir tune