summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorKevin Ryde <user42@zip.com.au>2002-03-13 00:39:03 +0100
committerKevin Ryde <user42@zip.com.au>2002-03-13 00:39:03 +0100
commit935df01ee2289fc977b30f6564bcc02acd40b0d7 (patch)
treeb6a5cbdfaecacb763127daf2fbcb60901ccb69b6 /configure.in
parent0e59ab86f06b2f1014ce368afc9cca8cd38a5b7c (diff)
downloadgmp-935df01ee2289fc977b30f6564bcc02acd40b0d7.tar.gz
* acinclude.m4, configure.in (GMP_C_DOUBLE_FORMAT): New macro.
And tweak a couple of comments.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 9 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index ca01a1154..2f01dd2a3 100644
--- a/configure.in
+++ b/configure.in
@@ -335,6 +335,11 @@ case $host in
# gas 2.10.0 doesn't accept -mev67, but -mev6 is enough for ctlz
# and cttz, as used by longlong.h on ev67.
#
+ # OSF `as' accepts ev68 but stupidly treats it as ev4. -arch only seems
+ # to affect insns like ldbu which are expanded as macros when necessary.
+ # Insns like ctlz which were never available as macros are always
+ # accepted and always generate their plain code.
+ #
case $host_cpu in
alpha) gcc_cflags_asm="-Wa,-arch,ev4 -Wa,-mev4" ;;
alphaev5) gcc_cflags_asm="-Wa,-arch,ev5 -Wa,-mev5" ;;
@@ -1550,8 +1555,8 @@ AC_HEADER_TIME
# sys/resource.h - not present in mingw
# sys/systemcfg.h - AIX specific
#
-# stdint.h, unistd.h and sys/types.h are already in the autoconf default
-# tests
+# inttypes.h, stdint.h, unistd.h and sys/types.h are already in the autoconf
+# default tests
#
AC_CHECK_HEADERS(locale.h sys/mman.h sys/param.h sys/processor.h sys/resource.h sys/sysctl.h sys/systemcfg.h sys/time.h sys/times.h)
@@ -1601,6 +1606,8 @@ case $ac_cv_c_bigendian in
*) AC_MSG_ERROR([Oops, unrecognised ac_cv_c_bigendian]) ;;
esac
+GMP_C_DOUBLE_FORMAT
+
# On m68k NetBSD 1.4.1 getrusage() is doubtful. ru_utime looks microsecond
# accurate but has been seen remaining unchanged after many microseconds