summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorKevin Ryde <user42@zip.com.au>2001-07-24 23:05:56 +0200
committerKevin Ryde <user42@zip.com.au>2001-07-24 23:05:56 +0200
commitdc0ee93b009c62bf8e644a4aff06ceb12a7da216 (patch)
tree0cefbe77fb8736cd36033c4317f827a1ac626d1b /configure.in
parent9322ffc406a474290051de600a6c28074b108840 (diff)
downloadgmp-dc0ee93b009c62bf8e644a4aff06ceb12a7da216.tar.gz
More of:
* configure.in (--enable-cxx): New option.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index fb3fc6d93..c93e3688b 100644
--- a/configure.in
+++ b/configure.in
@@ -87,14 +87,14 @@ esac],
AC_ARG_ENABLE(cxx,
-AC_HELP_STRING([--enable-cxx],[enable C++ support [default=detect]]),
+AC_HELP_STRING([--enable-cxx],[enable C++ support [default=no]]),
[case $enableval in
yes|no|detect) ;;
*)
AC_MSG_ERROR([bad value $enableval for --enable-alloca, need yes/no/detect])
;;
esac],
-[enable_cxx=detect])
+[enable_cxx=no])
AC_ARG_ENABLE(fft,
@@ -1109,8 +1109,8 @@ if test $enable_cxx != no; then
fi
AM_CONDITIONAL(HAVE_CXX, test $have_cxx = yes)
-# FIXME: This hack is because automake doesn't seem to like AM_CONDITIONAL
-# defined variables in libgmp_la_DEPENDENCIES.
+# FIXME: These hacks work around a couple of places automake 1.4f doesn't
+# like AM_CONDITIONALs.
if test $have_cxx = yes; then
PRINTF_CXX_OBJECTS='$(PRINTF_CXX_OBJECTS)'
LIBCXXPRINTF_LA='libcxxprintf.la'