summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorKevin Ryde <user42@zip.com.au>2001-07-24 01:56:40 +0200
committerKevin Ryde <user42@zip.com.au>2001-07-24 01:56:40 +0200
commita3a55d7d00fc5317af51198776f9592bd30907d2 (patch)
tree643d839ce84d444d783e60b41c819ad5ad185ac7 /configure.in
parent77ca02d155d612a2e5fc83a34f2275e5205d8a02 (diff)
downloadgmp-a3a55d7d00fc5317af51198776f9592bd30907d2.tar.gz
Change from:
* configure.in, acinclude.m4 (GMP_OPTION_CXX): New macro. To: * configure.in, acinclude.m4 (GMP_PROG_CXX): New macro. Need to have "if test $enable_cxx" in configure.in since otherwise the zany AC_REQUIRE mechanism drags in AC_PROG_CXXCPP at the wrong spot (ie. when we don't want C++). Also add sys/types.h: (AC_CHECK_HEADERS): Add locale.h and sys/types.h, remove unistd.h.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in23
1 files changed, 21 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 507ac7902..fe191f947 100644
--- a/configure.in
+++ b/configure.in
@@ -1091,7 +1091,26 @@ echo using ABI=\"$ABI\" CC=\"$CC\" CFLAGS=\"$CFLAGS\" CPPFLAGS=\"$CPPFLAGS\"
AC_PROG_CC
AC_PROG_CC_STDC
AC_PROG_CPP
-GMP_OPTION_CXX
+
+# The C++ compiler, if required
+have_cxx=no
+if test $enable_cxx != no; then
+ GMP_PROG_CXX
+fi
+AM_CONDITIONAL(HAVE_CXX, test $have_cxx = yes)
+
+# FIXME: This hack is because automake doesn't seem to like AM_CONDITIONAL
+# defined variables in libgmp_la_DEPENDENCIES.
+if test $have_cxx = yes; then
+ PRINTF_CXX_OBJECTS='$(PRINTF_CXX_OBJECTS)'
+ LIBCXXPRINTF_LA='libcxxprintf.la'
+else
+ PRINTF_CXX_OBJECTS=
+ LIBCXXPRINTF_LA=
+fi
+AC_SUBST(PRINTF_CXX_OBJECTS)
+AC_SUBST(LIBCXXPRINTF_LA)
+
case $host_cpu in
c90 | t90)
@@ -1261,7 +1280,7 @@ AC_HEADER_STDC
AC_HEADER_TIME
# inttypes.h and unistd.h are already in the autoconf default tests
-AC_CHECK_HEADERS(locale.h sys/mman.h sys/param.h sys/processor.h sys/resource.h sys/sysctl.h sys/systemcfg.h sys/time.h sys/times.h)
+AC_CHECK_HEADERS(locale.h sys/mman.h sys/param.h sys/processor.h sys/resource.h sys/sysctl.h sys/systemcfg.h sys/time.h sys/times.h sys/types.h)
# optarg should be in unistd.h, which is already in the default includes
AC_CHECK_DECLS(optarg)