summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTorbjorn Granlund <tege@gmplib.org>2011-07-04 00:15:44 +0200
committerTorbjorn Granlund <tege@gmplib.org>2011-07-04 00:15:44 +0200
commit764f2a4293633c78671be34867cc7f34125d7d95 (patch)
tree6a3694a67ee24a5997d4796bf8545ede565d4282 /configure.in
parentb38515c40e30003bab900357dcb2d5bd2278b390 (diff)
downloadgmp-764f2a4293633c78671be34867cc7f34125d7d95.tar.gz
(x86_64 *-*-mingw*): Handle also cygwin here; clear out extra_functions_64.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 4 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index 0b5d10a1e..e4cccf940 100644
--- a/configure.in
+++ b/configure.in
@@ -123,7 +123,7 @@ esac],
AC_ARG_ENABLE(assembly,
-AC_HELP_STRING([--enable-assembly],[enable the use of asembly loops [[default=yes]]]),
+AC_HELP_STRING([--enable-assembly],[enable the use of assembly loops [[default=yes]]]),
[case $enableval in
yes|no) ;;
*) AC_MSG_ERROR([bad value $enableval for --enable-assembly, need yes or no]) ;;
@@ -1548,9 +1548,10 @@ case $host in
cclist_64="$cclist_64 cc"
cc_64_cflags="-xO3 -m64"
;;
- *-*-mingw*)
+ *-*-mingw* | *-*-cygwin)
limb_64=longlong
path_64="" # Windows amd64 calling conventions are *different*
+ extra_functions_64=""
# Silence many pedantic warnings for w64. FIXME.
gcc_64_cflags="$gcc_64_cflags -std=gnu99"
;;
@@ -1572,10 +1573,7 @@ case $host in
;;
- # Special CPU "none" selects generic C. -DNO_ASM is used to disable gcc
- # asm blocks in longlong.h (since they're driven by cpp pre-defined
- # symbols like __alpha rather than the configured $host_cpu).
- #
+ # Special CPU "none" used to select generic C, now this is obsolete.
none-*-*)
AC_MSG_ERROR([the \"none\" host is obsolete, use --disable-assembly])
;;