summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorKevin Ryde <user42@zip.com.au>2001-10-09 03:38:33 +0200
committerKevin Ryde <user42@zip.com.au>2001-10-09 03:38:33 +0200
commitad2c34f6ab7c4279cdffd2336a4927094df9c12a (patch)
treeea2c81b996f3ffe1fb6eec8441e427b636678bae /Makefile.am
parent6ef030cf5fcf6905897ae4023a1e3a91ed2fb99a (diff)
downloadgmp-ad2c34f6ab7c4279cdffd2336a4927094df9c12a.tar.gz
* Makefile.am, cxx/Makefile.am: Updates for Gerardo's stuff.
2001-10-09 Gerardo Ballabio <ballabio@sissa.it> * cxx/isfuns.cc: New file. * cxx/ismpf.cc, cxx/ismpq.cc, cxx/ismpz.cc: New files. * gmpxx.h, mpfrxx.h: New files.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 35b6f8654..afe39f48a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -80,6 +80,13 @@ endif
#
SUBDIRS = tests mpn mpz mpq mpf printf cxx mpbsd $(MPFR_DIR) demos tune
+if WANT_CXX
+GMPXX_HEADERS_OPTION = gmpxx.h
+if WANT_MPFR
+MPFRXX_HEADERS_OPTION = mpfrxx.h
+endif
+endif
+include_HEADERS = $(GMPXX_HEADERS_OPTION) $(MPFRXX_HEADERS_OPTION)
nodist_include_HEADERS = gmp.h $(MPBSD_HEADERS_OPTION)
lib_LTLIBRARIES = libgmp.la $(GMPXX_LTLIBRARIES_OPTION) $(MPBSD_LTLIBRARIES_OPTION)
@@ -186,6 +193,7 @@ PRINTF_OBJECTS = \
printf/vsnprintf$U.lo printf/vsprintf$U.lo
CXX_OBJECTS = \
+ cxx/isfuns$U.lo cxx/ismpf$U.lo cxx/ismpq$U.lo cxx/ismpz$U.lo \
cxx/osdoprnti$U.lo cxx/osmpf$U.lo cxx/osmpq$U.lo cxx/osmpz$U.lo
MPBSD_OBJECTS = mpbsd/add$U.lo mpbsd/tdiv_qr$U.lo mpbsd/set$U.lo \