summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 11f51147..a92e30f3 100644
--- a/configure.in
+++ b/configure.in
@@ -224,6 +224,9 @@ if test "x$enable_use_deprecations" = "xyes"; then
AC_SUBST(DISABLE_DEPRECATED_CFLAGS)
fi
+# Offer the ability to omit some API from the library,
+# to reduce the code size:
+GLIBMM_ARG_ENABLE_API_EXCEPTIONS()
# Add an --enable-deprecated-api option:
AC_ARG_ENABLE(deprecated-api, [AC_HELP_STRING([--enable-deprecated-api],
@@ -237,6 +240,11 @@ AC_SUBST(DISABLE_DEPRECATED_API_CFLAGS)
AC_MSG_WARN([Deprecated API will not be built, breaking backwards-compatibility. Do not use this build for distribution packages.])
fi
+#Offer the ability to omit some API from the library,
+#to reduce the code size:
+GLIBMM_ARG_ENABLE_API_PROPERTIES()
+GLIBMM_ARG_ENABLE_API_VFUNCS()
+
# Dummy conditional just to make automake-1.4 happy.
# We need an always-false condition in docs/Makefile.am.