summaryrefslogtreecommitdiff
path: root/MSVC_NMake/gendef/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'MSVC_NMake/gendef/meson.build')
-rw-r--r--MSVC_NMake/gendef/meson.build9
1 files changed, 9 insertions, 0 deletions
diff --git a/MSVC_NMake/gendef/meson.build b/MSVC_NMake/gendef/meson.build
new file mode 100644
index 00000000..3dc9cc25
--- /dev/null
+++ b/MSVC_NMake/gendef/meson.build
@@ -0,0 +1,9 @@
+# MSVC_NMake/gendef
+
+# Input: is_msvc
+# Output: gendef
+
+# Used to generate the .def file required to obtain the import .lib file
+if is_msvc
+ gendef = executable('gendef', 'gendef.cc', install: false)
+endif