summaryrefslogtreecommitdiff
path: root/sysdeps/x86_64/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'sysdeps/x86_64/configure.in')
-rw-r--r--sysdeps/x86_64/configure.in7
1 files changed, 7 insertions, 0 deletions
diff --git a/sysdeps/x86_64/configure.in b/sysdeps/x86_64/configure.in
index 94bcd19f3c..3a38740bf0 100644
--- a/sysdeps/x86_64/configure.in
+++ b/sysdeps/x86_64/configure.in
@@ -21,6 +21,13 @@ if test $libc_cv_cc_avx = yes; then
AC_DEFINE(HAVE_AVX_SUPPORT)
fi
+dnl Check if -mavx -mprefer-avx128 works.
+AC_CACHE_CHECK(-mavx -mprefer-avx128 support, libc_cv_cc_avx128, [dnl
+LIBC_TRY_CC_OPTION([-mavx -mprefer-avx128],
+ [libc_cv_cc_avx128=yes],
+ [libc_cv_cc_avx128=no])
+])
+
dnl Check if -msse2avx works.
AC_CACHE_CHECK(for AVX encoding of SSE instructions, libc_cv_cc_sse2avx, [dnl
LIBC_TRY_CC_OPTION([-msse2avx],