summaryrefslogtreecommitdiff
path: root/sysdeps/nios2/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'sysdeps/nios2/configure.ac')
-rw-r--r--sysdeps/nios2/configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/sysdeps/nios2/configure.ac b/sysdeps/nios2/configure.ac
new file mode 100644
index 0000000000..f05f43802b
--- /dev/null
+++ b/sysdeps/nios2/configure.ac
@@ -0,0 +1,13 @@
+GLIBC_PROVIDES dnl See aclocal.m4 in the top level source directory.
+# Local configure fragment for sysdeps/nios2.
+
+# Nios II big endian is not yet supported.
+AC_CACHE_CHECK([for big endian],
+ [libc_cv_nios2_be],
+ [AC_EGREP_CPP(yes,[#ifdef __nios2_big_endian__
+ yes
+ #endif
+ ], libc_cv_nios2_be=yes, libc_cv_nios2_be=no)])
+if test $libc_cv_nios2_be = yes; then
+ AC_MSG_ERROR([Big endian not supported for Nios II])
+fi