summaryrefslogtreecommitdiff
path: root/sysdeps/arm/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'sysdeps/arm/configure.ac')
-rw-r--r--sysdeps/arm/configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/sysdeps/arm/configure.ac b/sysdeps/arm/configure.ac
index d66500b3fd..fdc52c0408 100644
--- a/sysdeps/arm/configure.ac
+++ b/sysdeps/arm/configure.ac
@@ -44,3 +44,16 @@ if test $libc_cv_arm_pcs_vfp = yes; then
else
LIBC_CONFIG_VAR([default-abi], [soft])
fi
+
+AC_CACHE_CHECK([whether the build tools support the GNU descriptor TLS scheme],
+ [libc_cv_arm_tls_desc],
+ [old_CFLAGS="$CFLAGS"
+ CFLAGS="$CFLAGS -mtls-dialect=gnu2"
+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([asm (".word\tfoo(tlsdesc)");], [])],
+ [libc_cv_arm_tls_desc=yes], [libc_cv_arm_tls_desc=no])
+ CFLAGS="$old_CFLAGS"])
+if test $libc_cv_arm_tls_desc = yes; then
+ LIBC_CONFIG_VAR([have-arm-tls-desc], [yes])
+else
+ LIBC_CONFIG_VAR([have-arm-tls-desc], [no])
+fi