summaryrefslogtreecommitdiff
path: root/ports/sysdeps/arm/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'ports/sysdeps/arm/Makefile')
-rw-r--r--ports/sysdeps/arm/Makefile34
1 files changed, 0 insertions, 34 deletions
diff --git a/ports/sysdeps/arm/Makefile b/ports/sysdeps/arm/Makefile
deleted file mode 100644
index b218e76eac..0000000000
--- a/ports/sysdeps/arm/Makefile
+++ /dev/null
@@ -1,34 +0,0 @@
-gnulib-arch = $(elfobjdir)/libgcc-stubs.a
-static-gnulib-arch = $(elfobjdir)/libgcc-stubs.a
-
-ifeq ($(subdir),elf)
-sysdep-dl-routines += tlsdesc dl-tlsdesc
-sysdep_routines += aeabi_unwind_cpp_pr1 find_exidx tlsdesc dl-tlsdesc
-sysdep-rtld-routines += aeabi_unwind_cpp_pr1 tlsdesc dl-tlsdesc
-shared-only-routines += aeabi_unwind_cpp_pr1
-
-$(objpfx)libgcc-stubs.a: $(objpfx)aeabi_unwind_cpp_pr1.os
- $(build-extra-lib)
-
-lib-noranlib: $(objpfx)libgcc-stubs.a
-endif
-
-ifeq ($(subdir),csu)
-# get offset to rtld_global._dl_hwcap
-gen-as-const-headers += rtld-global-offsets.sym tlsdesc.sym
-aeabi_constants = aeabi_lcsts aeabi_sighandlers aeabi_math
-aeabi_routines = aeabi_assert aeabi_localeconv aeabi_errno_addr \
- aeabi_mb_cur_max aeabi_atexit aeabi_memclr aeabi_memcpy \
- aeabi_memmove aeabi_memset
-
-sysdep_routines += $(aeabi_constants) $(aeabi_routines)
-static-only-routines += $(aeabi_constants)
-endif
-
-ifeq ($(subdir),gmon)
-sysdep_routines += arm-mcount
-endif
-
-ifeq ($(subdir),debug)
-CFLAGS-backtrace.c += -funwind-tables
-endif