summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 1 insertions, 10 deletions
diff --git a/configure.in b/configure.in
index d93ca5ca98..bd90bac91e 100644
--- a/configure.in
+++ b/configure.in
@@ -390,15 +390,6 @@ case "$machine-$host_os" in
;;
esac
-# Configure for i686 if the user asks for i386. We don't support
-# i386 any more but it continues to be common for users to configure
-# 32-bit x86 as i386. We build for i686 instead.
-if test "$machine" = i386; then
- machine="i686"
- echo "\
-*** WARNING: Support for i386 is deprecated. Building for i686 instead."
-fi
-
submachine=
AC_ARG_WITH([cpu],
AS_HELP_STRING([--with-cpu=CPU], [select code for CPU variant]),
@@ -576,7 +567,7 @@ changequote(,)dnl
# type and particular chip. If an add-on configure fragment already set
# base_machine, we don't change it.
test -n "$base_machine" || case "$machine" in
-i[34567]86) base_machine=i386 machine=i386/$machine ;;
+i[4567]86) base_machine=i386 machine=i386/$machine ;;
powerpc) base_machine=powerpc machine=powerpc/powerpc32 ;;
powerpc64) base_machine=powerpc machine=powerpc/powerpc64 ;;
s390) base_machine=s390 machine=s390/s390-32 ;;